QIP Home QIP Forum

Go Back   QIP Forum > Все для QIP 2012 > QIP 2012. Доступные модули и утилиты. Plugins.

QIP 2012. Доступные модули и утилиты. Plugins. Здесь постить сами модули(плагины), утилиты и темы для их обсуждения.

View Poll Results: Хотели бы вы показывать в статусе кроме названия трека и исполнителя другую инф-ю?
Нет, достаточно информации "Исполнитель - Название трека" 246 47.49%
Да, хотелось бы указывать дополнительную информацию — альбом, артист, название, номер трек и т.д 272 52.51%
Voters: 518. You may not vote on this poll | Withdraw Vote

Reply
 
Thread Tools Display Modes
Old 27.07.2007, 14:15   #1
Lex Luthor
QIP Newcomer
 
Lex Luthor's Avatar
 
Join Date: 06/2007
Posts: 94
Default Qip Music Status (QMS)

Скачать плагин: qms.zip

ОПИСАНИЕ
Назначение: плагин позволяет устанавливать расширенный статус в соответствии с воспроизводимой на данный момент в музыкальном проигрывателе композицией
Текущая версия: Qip Music Status (qms.dll) v.0.75 на базе SDK 1.6
Версии QiP: QiP Infium, QiP 2010
Автор: worldwidespider на основе версии от Lex Luthor
Проигрыватели: Winamp, Apollo 37zz, AIMP 2, foobar2000 (с вариантами интерфейса Default и Columns UI), Last.Fm, MediaMonkey, Media Player Classic, KMPlayer, Spider Player, Light Alloy и другие. Некоторые требуют дополнительной подстройки не только в настройках плагина, но и в файле определений проигрывателей для более полного использования информации (см. ниже ДОП. ИНСТРУКЦИИ).
Известные проблемы: iTunes и Windows Media Player не поддерживаются, однако есть положительный результат использования плагина QMS совместно с Windows Media Player, если в последнем установлен плагин Last.Fm, поддержка проигрывателя Jet Audio не однозначна - проигрыватель определяется, но у многих информация искажена.
В последней версии: обновлен файл с описаниями проигрывателей, устранена проблема с частой сменой статуса при отсутствии запущенного проигрывателя и включенной опции автоустановки статуса, улучшена поддержка Last.Fm скробблера и его плагинов.

[+] Клик на строке - дополнительная информация

УСТАНОВКА
Стандартная установка из qms.zip (содержимое архива - папка qms, распаковать ее в папку plugins вашего Qip Infium). Обновление либо вручную аналогично установке, либо через PluginUpdater.

СВЕДЕНИЯ О РАЗРАБОТКЕ
(последния события и планы)

Lex Luthor на данный момент оставил разработку плагина.
Шапку данной темы редактирует worldwidespider, он же автор последней версии.

проект временно заморожен.

ДОП. ИНСТРУКЦИИ
Желающим попытаться добавить поддержку своего проигрывателя или перенастроить что-то у уже определяющихся проигрывателей будет полезно сообщение #1090.

О настройке под AIMP3
Достаточно сделать следующее:
  1. Открыть в каталоге плагина файл с определениями проигрывателей qms.ini
  2. Найти секцию [AIMP2] и скопировать ее содержимое от самого названия секции до первой пустой строки ниже.
  3. Вставить скопированный фрагмент в конце файла с новой строки
  4. Исправить во вставленном фрагменте AIMP2 на AIMP3 в двух местах: в названии секции и в строке с Executable.
  5. Сохранить отредактированный файл.
Способ для ленивых (короче и проще, но потеряете определение AIMP2):
  1. Открыть в каталоге плагина файл с определениями проигрывателей qms.ini
  2. Найти секцию [AIMP2].
  3. Исправить в ней AIMP2 на AIMP3 в двух местах: в названии секции и в строке с Executable.
  4. Сохранить отредактированный файл.

Для PluginUpdater
Этот раздел содержит техническую информацию, необходимую для успешного обновления через PluginUpdater.

[+] Updater: Technical Info


Примечание.
Во вложении ниже находится полный исходный код плагина и сопутствующих утилит.
Ссылка на сам плагин в первой строке.
Утилиты на форуме не размещаются.
Attached Files
File Type: zip full_source_0_75.zip (122.8 KB, 17069 views)

Last edited by WorldWideSpider; 27.06.2011 at 09:43.
Lex Luthor вне форума   Reply With Quote
Old 28.07.2007, 07:32   #2
Providence
Specially for Natly
 
Providence's Avatar
 
Join Date: 06/2007
Posts: 10,560
Default

Lex Luthor, спасибо, всё работает!! Есть несколько пожеланий, которые напишу в аську ;)
Providence вне форума   Reply With Quote
Old 28.07.2007, 10:19   #3
Lex Luthor
QIP Newcomer
 
Lex Luthor's Avatar
 
Join Date: 06/2007
Posts: 94
Default

Спасибо,сейчас думаю над поддержкой различных плееров и делаю окно опций.
Lex Luthor вне форума   Reply With Quote
Old 28.07.2007, 12:39   #4
Spir1tus
Reading Only
 
Join Date: 07/2007
Posts: 7
Default

Quote:
Originally Posted by Lex Luthor View Post
Похожий на предидущий плагин только мой плагин поддерживает ещё и плеер AIMP. С кодом особо не заморачивался,писал для себя так что можете использовать мой код сколько хотите.;) Естественно нужен qip с поддержкой sdk. Особо за косяки не ругать
************************************************** ************************
Исправил несколько недостатков. Думаю завтра сделаю возможность выбора самому указать текст вашего статуса.
Предыдущий вроде тоже прекрасно поддерживает. Или нет?
Spir1tus вне форума   Reply With Quote
Old 28.07.2007, 12:48   #5
Providence
Specially for Natly
 
Providence's Avatar
 
Join Date: 06/2007
Posts: 10,560
Default

Spir1tus, предыдущий лично у меня не работает вообще и AIMP он не поддерживает ;)
Providence вне форума   Reply With Quote
Old 28.07.2007, 13:21   #6
Spir1tus
Reading Only
 
Join Date: 07/2007
Posts: 7
Default

Quote:
Originally Posted by Providence View Post
Spir1tus, предыдущий лично у меня не работает вообще и AIMP он не поддерживает ;)
Если тебе влом в настройках AIMP поставить "Эмулировать Winamp", то что ж поделат -
нужен новый плагин. :D
Spir1tus вне форума   Reply With Quote
Old 28.07.2007, 13:28   #7
CapDaughter
Miss Moderator
 
CapDaughter's Avatar
 
Join Date: 12/2006
Posts: 2,206
Question

Quote:
Originally Posted by Spir1tus View Post
Если тебе влом в настройках AIMP поставить "Эмулировать Winamp", то что ж поделат -
нужен новый плагин. :D
У меня упоминаемая "галка" стоит, однако плагин в qip 8030 при использовании AIMP не работает, только Winamp
В qip infinium не удалось настроить, подозрение что я просто туплю где то жестко, ток не знаю где :D

Last edited by CapDaughter; 28.07.2007 at 13:30. Reason: Добавлено сообщение
CapDaughter вне форума   Reply With Quote
Old 28.07.2007, 13:34   #8
Spir1tus
Reading Only
 
Join Date: 07/2007
Posts: 7
Default

Quote:
Originally Posted by CapDaughter View Post
У меня упоминаемая "галка" стоит, однако плагин в qip 8030 при использовании AIMP не работает, только Winamp
В qip infinium не удалось настроить, подозрение что я просто туплю где то жестко, ток не знаю где :D
Если я не ошибаюсь тут речь про Infinium идет.
Spir1tus вне форума   Reply With Quote
Old 28.07.2007, 13:37   #9
CapDaughter
Miss Moderator
 
CapDaughter's Avatar
 
Join Date: 12/2006
Posts: 2,206
Smile

Quote:
Originally Posted by Spir1tus View Post
Если я не ошибаюсь тут речь про Infinium идет.
да, про него, на предыдущий qip и его плагины я забила уже )) это было так, лирическое отступление

Quote:
Originally Posted by CapDaughter View Post
В qip infinium не удалось настроить, подозрение что я просто туплю где то жестко, ток не знаю где :D
CapDaughter вне форума   Reply With Quote
Old 28.07.2007, 13:43   #10
Spir1tus
Reading Only
 
Join Date: 07/2007
Posts: 7
Default

Самое интересное, что без опции "эмулирования" данный плагин тож не пашет.
И правильно, ведь в коде я не нашел ни одной строчки, которая показывает, что плаг сделан с поддержкой AIMP("эмуляция Winamp"- это встроенная функция AIMP). Пусть автор покажет.


Quote:
Originally Posted by CapDaughter View Post
В qip infinium не удалось настроить, подозрение что я просто туплю где то жестко, ток не знаю где :D
Что именно?
Не смогла плагин загрузить ? или он не работает загруженный?

Last edited by Spir1tus; 28.07.2007 at 13:45. Reason: Добавлено сообщение
Spir1tus вне форума   Reply With Quote
Old 28.07.2007, 13:47   #11
CapDaughter
Miss Moderator
 
CapDaughter's Avatar
 
Join Date: 12/2006
Posts: 2,206
Default

Quote:
Originally Posted by Spir1tus View Post
Что именно?
да там вроде и премудрого то ничего нет
подозреваю что дело в этом: "Естественно нужен qip с поддержкой sdk" - ток как понять, с поддержкой он или нет? объясните ламеру
CapDaughter вне форума   Reply With Quote
Old 28.07.2007, 13:56   #12
Spir1tus
Reading Only
 
Join Date: 07/2007
Posts: 7
Default

Quote:
Originally Posted by CapDaughter View Post
да там вроде и премудрого то ничего нет
подозреваю что дело в этом: "Естественно нужен qip с поддержкой sdk" - ток как понять, с поддержкой он или нет? объясните ламеру
А откуда взят Infinium? Просто на главной странице он без поддержки SDK.
А в разделе для разработчиков в архиве с SDK, как раз-то с поддержкой.
Вот здесь - http://forum.qip.ru/showthread.php?t=17705.
А если это этот Infifnium, то просто папку с плагином (именно саму паку с плагином, а не только dll) копируем в паку Plugins Infiniuma
Spir1tus вне форума   Reply With Quote
Old 28.07.2007, 14:01   #13
CapDaughter
Miss Moderator
 
CapDaughter's Avatar
 
Join Date: 12/2006
Posts: 2,206
Talking

Quote:
Originally Posted by Spir1tus View Post
А откуда взят Infinium? Просто на главной странице он без поддержки SDK.
А в разделе для разработчиков в архиве с SDK, как раз-то с поддержкой.
Вот здесь - http://forum.qip.ru/showthread.php?t=17705.
Конечно в раздел для разработчиков не лезла, там ж написано - "для разработчиков" :D
поставлю, проверю, отпишусь :)
CapDaughter вне форума   Reply With Quote
Old 28.07.2007, 14:04   #14
Sega-Zero
QIP Developer
 
Sega-Zero's Avatar
 
Join Date: 05/2006
Posts: 1,683
Default

Интересно, где вы Infinium нашли... Я только Infium вижу.
__________________
www.sega-zero.blogspot.com <- как продвигается работа
Sega-Zero вне форума   Reply With Quote
Old 28.07.2007, 14:39   #15
CapDaughter
Miss Moderator
 
CapDaughter's Avatar
 
Join Date: 12/2006
Posts: 2,206
Talking

Quote:
Originally Posted by Sega-Zero View Post
Интересно, где вы Infinium нашли... Я только Infium вижу.
мда, что то глючит у меня в мозхе файлег с названиями :D да простят мну разработчеги второй раз замечание от "больших людей" получаю :D
еще возьмут и забанят :D
CapDaughter вне форума   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +4. The time now is 12:28.


Powered by vBulletin.
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
©2004 - 2012 QIP.RU